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ΕΡΓΑΣΤΗΡΙΟ 14o 
 
 

FRONT PAGE 2 
 

 
Μάθαµε στο προηγούµενο µάθηµα πώς να δίνουµε ονόµατα στις ιστοσελίδες µας, να 

βάζουµε χρώµα και γραφικά, ή ακόµα να δηµιουργούµε υπερσυνδέσµους σε κείµενο 

και εικόνες. 

Σήµερα µεταξύ άλλων θα ασχοληθούµε µε τη διαχείριση και τη οµοιόµορφη 

διαµόρφωση του δικτυακού µας τόπου. 

 

Πίνακες 

Οι πίνακες είναι ιδιαίτερα χρήσιµοι όταν θέλουµε να απεικονίσουµε πληροφορία σε 

στήλες και γραµµές.  

Για να δηµιουργήσετε έναν πίνακα τοποθετείστε τον κέρσορα  στο σηµείο της 

σελίδας που θέλετε να δηµιουργηθεί. Στο µενού πατήστε το κουµπί Insert Table. 

Εµφανίζεται ένα πλέγµα. Με τον δείκτη του ποντικιού επιλέξτε τον αριθµό των 

στηλών και των γραµµών που θέλετε και πατήστε αριστερό κλικ για να 

επιβεβαιώσετε την επιλογή σας. Αµέσως εµφανίζεται στην οθόνη ο νέος πίνακας. 

 

 
 

Ρυθµίστε το µέγεθος, το χρώµα και την θέση των περιθωρίων του πίνακά σας. 

Τοποθετήστε τον κέρσορα στον πίνακα. Στη γραµµή εργαλείων επιλέξτε Table -> 

Properties -> Table. Εµφανίζεται ο πίνακας διαλόγου από τον οποίο ελέγχονται οι 

ιδιότητες του πίνακα. 

 

Αν θέλατε µε κώδικα HTML να ορίσετε έναν πίνακα 3X3 τότε ο κώδικας που θα 

χρησιµοποιούσατε θα µοιάζει κάπως έτσι: 
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<table border="2" width="100%" bordercolorlight="#000080" bgcolor="#FFFF00"> 
  <tr> 
    <td width="33%">&nbsp;</td> 
    <td width="33%">&nbsp;</td> 
    <td width="34%">&nbsp;</td> 
  </tr> 
  <tr> 
    <td width="33%">&nbsp;</td> 
    <td width="33%">&nbsp;</td> 
    <td width="34%">&nbsp;</td> 
  </tr> 
  <tr> 
    <td width="33%">&nbsp;</td> 
    <td width="33%">&nbsp;</td> 
    <td width="34%">&nbsp;</td> 
  </tr> 
</table> 
 

 
 

Από το διαλογικό µενού που εµφανίζεται µπορούµε να ελέγξουµε το µέγεθος και το 

χρώµα των γραµµών που αποτελούν τα όρια του πίνακα, να ελέγξουµε το φόντο του 

πίνακα στο οποίο µπορούµε να τοποθετήσουµε και κάποια εικόνα,, ή ακόµα να 

ρυθµίσουµε τη σχετική θέση του πίνακα µέσα στην ιστοσελίδα. 
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Προσθέστε κείµενο και εικόνες στους πίνακες. 

Το να προσθέσετε κείµενο στους πίνακες είναι µάλλον προφανές. Τοποθετείτε τον 

κέρσορα µέσα σε κάθε κελί που θέλετε να γράψετε κάτι και το γράφετε. Με 

αντίστοιχη διαδικασία τοποθετείτε στον πίνακα και εικόνες.Insert -> Picture -> …. Ή 

χρησιµοποιώντας το κατάλληλο κουµπί από τη γραµµή εργαλείων  .  

Αν συµπληρώνοντας τον πίνακα διαπιστώσετε ότι χρειάζεται να προσθέσετε κι άλλα 

κελιά µπορείτε να το κάνετε από το µενού Table -> Insert -> Row ή Columns. Από το 

διαλογικό µενού που εµφανίζεται µπορείτε να επιλέξετε αν θέλετε να εισαγάγετε 

γραµµές ή στήλες, πόσες και µάλιστα προς ποια θέση σχετικά µε τον κέρσορα. 
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Προεπισκόπηση ιστοσελίδας 

Από τη στιγµή που ξεκινήσατε να κατασκευάζετε την ιστοσελίδα σας, είναι καλό σε 

τακτά χρονικά διαστήµατα να ελέγχετε πως φαίνεται από κάποιο πρόγραµµα 

πλοήγησης ιστοσελίδων (όπως ο Internet Explorer ή ο Netscape Navigator). Μια 

λύση είναι να σώσετε τη δουλειά σας, να κλείσετε τα σχετικά αρχεία και µετά να τα 

ανοίξετε από κάποιο από τα παραπάνω προγράµµατα. Το FrontPage σας δίνει τη 

δυνατότητα να  κάνετε προεπισκόπηση των σελίδων µέσα από το ίδιο µε τη χρήση 

του κατάλληλου κουµπιού που βρίσκεται στη γραµµή εργαλείων . 

Από την άλλη πρέπει να γνωρίζετε ότι αποκλείεται όλοι οι αναγνώστες των 

ιστοσελίδων σας να χρησιµοποιούν το ίδιο πρόγραµµα πλοήγησης. Άλλοι 

χρησιµοποιούν τον Internet Explorer άλλοι to Netscape Navigator. Και για να 

µπερδέψουµε τα πράγµατα ακόµα περισσότερο, άλλοι θα έχουν την πιο καινούργια 

έκδοση των προγραµµάτων και άλλοι κάποια από τις παλιότερες.  

Σε κάθε περίπτωση προσθέτοντας ιδιαίτερα χαρακτηριστικά στις ιστοσελίδες σας, δεν 

είναι σίγουρο ότι θα δουλεύουν σε όλα τα προγράµµατα. Υπάρχει περίπτωση κάποιες 

ιστοσελίδες να µην εµφανίζονται καθόλου σε συγκεκριµένες εκδόσεις (κυρίως 
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παλιότερες) των προγραµµάτων αυτών. Για το λόγο αυτό είναι καλό να αποφασίσετε 

πριν ακόµα την κατασκευή των ιστοσελίδων σας για ποιο πρόγραµµα πλοήγησης τις 

φτιάχνετε. Αν πάρετε αυτή την απόφαση, και την ανακοινώσετε µε κάποιον τρόπο 

στο FrontPage αυτό θα αναλάβει να περιλαµβάνει στις σελίδες σας µόνο 

χαρακτηριστικά που θα υποστηρίζονται και από τον συγκεκριµένο Browser. Αυτό 

επιτυγχάνεται διότι το πρόγραµµα δεν θα σας δίνει καν τη δυνατότητα να 

χρησιµοποιήσετε χαρακτηριστικά από τα µενού του που δεν υποστηρίζονται από τον 

browser που διαλέξατε. 

 

ΠΙΝΑΚΑΣ Ι. Χαρακτηριστικά που υποστηρίζονται από τα πιο διαδεδοµένα 

προγράµµατα πλοήγησης. 

Πλοηγός έκδοση ActiveX 
controls VBScript JavaScript Java 

applets
Dynamic 
HTML Frames CSS 

1.0 
CSS 
2.0 

Internet 
Explorer 

4.0 and 
later enabled enabled enabled enabled enabled enabled enabled enabled

Internet 
Explorer 

3.0 and 
later enabled enabled enabled enabled disabled enabled enabled disabled

Netscape 
Navigator 

4.0 and 
later disabled disabled enabled enabled enabled enabled enabled enabled

Netscape 
Navigator 

3.0 and 
later disabled disabled enabled enabled disabled enabled disabled disabled

Both 
Internet 
Explorer 
and 
Navigator 

4.0 and 
later disabled disabled enabled enabled enabled enabled enabled enabled

Both 
Internet 
Explorer 
and 
Navigator 

3.0 and 
later disabled disabled enabled enabled disabled enabled disabled disabled

Microsoft 
WebTV unavailable disabled disabled disabled disabled disabled disabled disabled disabled

 

Για να επιλέξετε τον πρόγραµµα πλοήγησης για το οποίο κατασκευάζετε τη σελίδα 

σας: Tools -> Page Options … 

Εµφανίζεται το µενού Page Options … Από το Compatibility Tab επιλέξτε το µενού 

Browsers. Εκεί επιλέξτε τους browsers που θέλετε να υποστηρίζουν τις σελίδες σας. 

Συνίσταται να επιλέξετε και τους δύο. Από κάτω επιλέγετε την έκδοση των 
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προγραµµάτων αυτών. Όσο πιο καινούργια είναι η έκδοση τόσο πιο πολλά 

χαρακτηριστικά θα υποστηρίζονται. 

Για να µάθετε ποια είναι η έκδοση του δικού σας προγράµµατος πλοήγησης, απλά 

τρέξτε το και πηγαίνετε στο µενού Help -> About. 

 

 

 
 

∆ιόρθωση σφαλµάτων – ορθογράφος  

Η διαδικασία διόρθωσης σφαλµάτων στο FrontPage λειτουργεί όπως και στο Word. 

Αν θελήσετε να ενεργοποιήσετε ή να απενεργοποιήσετε τη διαδικασία αυτή πρέπει να 

πάτε πάλι στο µενού Page Options αλλά να επιλέξετε το General Tab. 
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Έλεγχος και οργάνωση δικτυακού τόπου 

Υπάρχουν έξι διαφορετικές οπτικές γωνίες για να δείτε το δικτυακό σας τόπο στο 

FrontPage. Αυτές είναι: 

 
1. Page View. Εκεί που κατασκευάζεις και διορθώνεις τις σελίδες σου. 

2. Folders View. Εκεί βλέπεις όλες τις σελίδες που αποτελούν τον δικτυακό σου 

τόπο. Επίσης βλέπεις όλα τα ονόµατα των αρχείων και των γραφικών για κάθε 

σελίδα. 

3. Reports View. Εκεί ελέγχεις τους υπερσυνδέσµους µεταξύ των σελίδων, των 

γραφικών, και των αρχείων. Υπάρχουν επίσης αναφορές (reports) σχετικά µε 

την ταχύτητα φόρτωσης των σελίδων, χαµένους συνδέσµους, και άλλα. 
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4. Navigation View. Εκεί ασχολείσαι µε τον τρόπο που κάποιος επισκέπτης θα 

περιηγείται στο δικτυακό σου τόπο. Επίσης µπορείς να δηµιουργήσεις 

γραµµές πλοήγησης. 

5. Hyperlinks View. Εκεί εµφανίζονται όλα τα αντικείµενα που συνδέονται 

µεταξύ τους στο site. Επίσης φαίνονται σπασµένοι υπερσύνδεσµοι. 

6. Tasks View. Εκεί καταγράφεις τις εργασίες που πρέπει να γίνουν, δίνεις 

προτεραιότητες και ελέγχεις ποιος θα τις κάνει. 

 

Οργάνωση του δικτυακού τόπου 

Όπως είπαµε πιο πάνω το Navigation View δείχνει πως είναι συνδεδεµένες µεταξύ 

τους οι σελίδες του δικτυακού τόπου. Το σχετικό παράθυρο είναι χωρισµένο σε δύο 

τµήµατα. Το αριστερό παρουσιάζει τον κατάλογο των αρχείων και των 

υποκαταλόγων από τα οποία αποτελείται το site. Το δεξί παρουσιάζει κάποια κουτιά 

που αναπαριστούν τις σελίδες του δικτυακού σας τόπου και τον τρόπο µε τον οποίο 

είναι συνδεδεµένες µεταξύ τους. 

 
Όποτε φτιάχνετε ένα καινούργιο δικτυακό τόπο, το FrontPage δηµιουργεί κι έναν 

υποκατάλογο µε το όνοµα _private (ιδιωτικός). Σε αυτόν µπορείτε να τοποθετήσετε 

αρχεία που χρησιµοποιείτε µέσα στον τόπο σας αλλά δεν θέλετε άλλοι να τα βλέπουν. 

Για παράδειγµα, µπορεί να έχετε µια βάση δεδοµένων από τη οποία να παρουσιάζετε 

κάποια στοιχεία χωρίς να επιτρέπετε την πρόσβαση σε όλη τη βάση. 
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Επίσης το FrontPage δηµιουργεί κι έναν υποκατάλογο µε τον τίτλο images (εικόνες) 

στον οποίο µπορείτε να αποθηκεύετε όλες τις εικόνες που χρησιµοποιείται στο site, 

ώστε να είστε οργανωµένοι. 

 

Επέκταση του δικτυακού τόπου 

Αν θελήσετε να προσθέσετε µια καινούργια σελίδα στον δικτυακό σας τόπο, πατήστε 

το πλήκτρο New Page στη γραµµή εργαλείων . Αµέσως εµφανίζεται ένα αρχείο 

µε το όνοµα new_page_1.htm στη λίστα των υποκαταλόγων, κι ένα κουτί µε το 

όνοµα New Page 1 στο δεξί παράθυρο. Μπορείτε να αλλάξετε αυτά τα ονόµατα από 

το  µενού που εµφανίζεται αν κάνετε δεξί κλικ πάνω στο όνοµα του αρχείου. Μην 

ξεχάσετε να αφήσετε την κατάληξη .htm στο τέλος του αρχείου. 

Όταν είστε στο Navigation View, µπορείτε µε διπλό κλικ να ανοίξετε ένα αρχείο σαν 

να είναι σε Page View και από εκεί να κάνετε προσθήκες, διορθώσεις ή να το 

φτιάξετε από την αρχή. 

  

Υπάρχουν και άλλοι τρόποι για να φτιάξετε µια ιστοσελίδα.  

Το FrontPage είναι µέρος του Microsoft Office. Για το λόγο αυτό η λειτουργία του 

έχει πολλά κοινά στοιχεία µε τα υπόλοιπα προγράµµατα του πακέτου αυτού. Η 

συνεργασία µεταξύ τους σας επιτρέπει να σώσετε κάποια αρχεία των άλλων 

προγραµµάτων, π.χ. Word ή Excel, µε τη µορφή ιστοσελίδων. Με τον τρόπο αυτό 

µπορείτε να τα ενσωµατώσετε άµεσα µέσα στον δικτυακό σας τόπο. Η διαδικασία 

είναι πολύ απλή. Έστω ότι έχετε ήδη ένα κείµενο που είναι γραµµένο σε Word και 

θέλετε να το εντάξετε στον δικτυακό σας τόπο. Σώστε το από το Word µέσω του 

µενού Save As… µέσα στον κατάλογο που περιέχεται το web σας, δίνοντας του όποιο 

όνοµα θέλετε και ως κατάληξη .htm. Αν τώρα πάτε στο FrontPage θα δείτε ότι το 

αρχείο αυτό εµφανίζεται µέσα στον κατάλογο του δικτυακού σας τόπου. 

  

∆ώστε µια οµοιόµορφη «διάθεση» στον δικτυακό σας τόπο. 

Μπορείτε να δώσετε στο site σας µια ενιαία οπτική εµφάνιση χρησιµοποιώντας 

προσχεδιασµένα θέµατα. Το FrontPage διαθέτει 60 περίπου τέτοια προσχεδιασµένα 

θέµατα (themes). Με τον τρόπο αυτό επιτυγχάνετε µια οµοιόµορφη εµφάνιση για τις 

σελίδες σας. Κάθε θέµα περιέχει συντονισµένα χρώµατα, γραµµατοσειρές, εικόνες, 

γραµµές πλοήγησης, κουκίδες κ.α. 
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Για να εισάγετε κάποιο θέµα στις σελίδες σας πηγαίνετε από το µενού Format -> 

Themes. Επιλέξτε το κουµπί All Pages. ∆ιαλέξτε το θέµα που σας αρέσει. Πατήστε 

ΟΚ. 

 

 
 

Μπορείτε να αλλάξετε τα χαρακτηριστικά των θεµάτων αφού τα εφαρµόσετε στην 

ιστοσελίδα σας. Μπορείτε να αλλάξετε τα χρώµατα, τα γραφικά ή τα στυλ. Όλα αυτά 

γίνονται εύκολα από το µενού Modify… που βλέπετε χαµηλά στην προηγούµενη 

εικόνα.  

 

Κοινά όρια (shared borders) 

Τα κοινά όρια ή σύνορα είναι µια περιοχή σε µια σελίδα που είναι κοινή για κάθε 

σελίδα. Μπορείτε για παράδειγµα να χρησιµοποιήσετε shared border αν θέλετε να 

έχετε την ίδια γραµµή στο τέλος κάθε σελίδας σας. Μια τέτοια κοινή γραµµή µπορεί 

να είναι το όνοµα της εταιρείας στην οποία ανήκει ο δικτυακός τόπος, το όνοµα 

αυτού που σχεδίασε τις σελίδες και κάποιο e-mail επικοινωνίας. Όταν θέλετε να 

αλλάξετε αυτό το κείµενο, κάνετε την αλλαγή µόνο σε µια σελίδα κι αυτή 

εµφανίζεται σε όλες. 

Για να φτιάξετε µια τέτοια περιοχή πηγαίνετε στο µενού Format -> Shared Borders. 

Πατήστε το κουµπί (check box) που αναφέρεται στην περιοχή της σελίδας στην οποία 
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θέλετε να έχετε το κοινό όριο. Πατήστε ΟΚ. Μετά τοποθετείστε τον κέρσορα µέσα 

στο όριο και γράψτε το κείµενο που θέλετε. ∆είτε ότι αυτό παρουσιάζεται πλέον σε 

κάθε σελίδα. 

 

 
 

Εργασία 

1. Εφαρµόστε όλα τα παραπάνω στις ιστοσελίδες που φτιάξατε στο προηγούµενο 

εργαστήριο.  

2. Φτιάξτε έναν δικτυακό τόπο και δηµιουργήστε συνδέσµους µεταξύ των σελίδων. 

3. Βάλτε ένα κοινό θέµα της αρεσκείας σας σε όλες τις σελίδες. 

4. Ορίστε στο κάτω µέρος των σελίδων µια περιοχή όπου θα αναφέρεται το όνοµά 

σας, ως σχεδιαστή της σελίδας, καθώς και ένα e-mail για επικοινωνία. 

  


